profile

이 세상에 하나는 남기고 가자

세상에 필요한 소스코드 한줄 남기고 가자

Could not find com.android.support.constraint:constraint-layout 오류 해결

유영재

안드로이드에서 ConstraintLayout를 사용하기 위해 아래와 같이 gradle에 설정했었다.

dependencies {
    compile 'com.android.support.constraint:constraint-layout:1.0.0-alpha9'
}

업데이트가 있는지 확인해 보니 1.0.1이 있기에 아래와 같이 변경했다.

dependencies {
    compile 'com.android.support.constraint:constraint-layout:1.0.1'
}

그리고 빌드를 해려고 했더니 아래와 같은 오류가 났다.

Error:Could not find com.android.support.constraint:constraint-layout:1.0.1.
Required by:myapp:app:unspecified

관련 정보를 검색해 보니 아래와 같이 설정이 필요하다.

could-not-find-comandroidsupportconstraintconstraint-layout-1

"Settings -> Appearance & Behavior -> System Settings -> Android SDK -> SDK Tools" 에서 "ConstraintLayout for Android" 를 체크해서 사용 가능하도록 해줘야 한다.

나의 경우는 기존에 사용했었기 때문에 체크는 되어 있었으나 업데이트가 되지 않아서 발생한 문제였다. 다시 체크하여 업데이트를 받고 나니 정상적으로 빌드가 완료되었다.

comments powered by Disqus